const regex = new RegExp('(<a\\s+href="http:(?!\\/\\/(?:www\\.)?example\\.com)[^"]*")>', 'isg')
const str = `<a href="/somepage.htm">1</a>
<a href="http://www.somesiteexternal.com/">2</a>
<a href="http://www.example.com/somepage.htm">3</a>
`;
const subst = `\1 target="_blank">`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);