use strict;
my $str = '<a href="/somepage.htm">1</a>
<a href="http://www.somesiteexternal.com/">2</a>
<a href="http://www.example.com/somepage.htm">3</a>
';
my $regex = qr~(<a\s+href="http:(?!\/\/(?:www\.)?example\.com)[^"]*")>~isp;
my $subst = '\\1 target="_blank">';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";