#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mis)(hello.*?)(?=hello|\z)"
Local $sString = "hello i am xyz lol hello i" & @CRLF & _
"am abc ..;sda<>" & @CRLF & _
"hello" & @CRLF & _
"i am pqr ahe kiop hello" & @CRLF & _
"abc axyz" & @CRLF & _
"no" & @CRLF & _
"yes " & @CRLF & _
"hepdd" & @CRLF & _
"jol" & @CRLF & _
"hello" & @CRLF & _
"podjkd" & @CRLF & _
"dasfh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")