#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:[^"#]*".*"[^"#]*|[^"#]*)(#.*)?$"
Local $sString = "{ # comment 1" & @CRLF & _
" "hello": "Wor#d", "Bye": "\"M#rk\"",# comment" 2" & @CRLF & _
" "quote": "\"th#t's\" what she said", # comment 3" & @CRLF & _
" "list": [1, 1, "#", "\"", 5, 8] # comment 4 with "quotes"" & @CRLF & _
"}" & @CRLF & _
"# comment 5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")