import re
regex = re.compile(r"^(?:[^\"#]*\".*\"[^\"#]*|[^\"#]*)(#.*)?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("{ # comment 1\n"
" \"hello\": \"Wor#d\", \"Bye\": \"\\\"M#rk\\\"\",# comment\" 2\n"
" \"quote\": \"\\\"th#t's\\\" what she said\", # comment 3\n"
" \"list\": [1, 1, \"#\", \"\\\"\", 5, 8] # comment 4 with \"quotes\"\n"
"}\n"
"# comment 5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")