$re = '/(?<=\p{L})(?=[\d\W])|(?<=\W)(?=(?<!\d)\d)/m';
$str = 'ab-1234
xyz123
omega-3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);