using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(o(?>o(?>o(?>o(?>o(?>o(?>oo)?o)?o)?o)?o)?o)?o)";
string input = @"oooooo";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}