re = /cr((?!cr)[^.])*(?=\.[^.]+$)/m
str = 'cr US TRUMP DE NIRO 20161008cr_x080b.wmv
crcrUS TRUMP DE NIRO 20161008cr.xml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end