$re = '/(?:[^)(]*\(|\)[^)(]*)(*SKIP)(*F)|\s/m';
$str = 'foobar baz blah (some sample text in here) and some more
a b c (d e f) g ( )
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;