package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(.*?)Section title:`)
var str = `this is the Section title:text for the section`
var substitution = "Section title: $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}