const regex = /\d{1,4}\s*kJs\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,4}\\s*kJs\\b', 'gm')
const str = `400kJs and 1000kJs`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);