use strict;
my $str = '400kJs and 1000kJs';
my $regex = qr/\d{1,4}\s*kJs\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";