$re = '/^[1][0]\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.[0]\.[0]/';
$str = '10.25.0.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);