(?i)applies the following effective flags to the remainder of the pattern: gmi i modifier: insensitive. Matches without distinguishing uppercase and lowercase letters
^start of line
\D{2,}any character that's not a digit, repeated at least 2 times
\.the literal . (4610 / 568 / 2E16)
\Dany character that's not a digit
\.the literal . (4610 / 568 / 2E16)
\D{2}any character that's not a digit, repeated exactly 2 times
.*any character (except for line terminators), repeated any number of times
$end of line
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string