using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!\[\]\(https.*(\.png|\.jpg)\)";
string input = @"
{:height 40, :width 80}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}