package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)!\[\]\(https.*(\.png|\.jpg)\)`)
var str = `
{:height 40, :width 80}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}