package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)the (big|small|biggest) (cat|dog|bird)`)
var str = `the big dog
the small bird
the biggest dog
the small cat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}