const regex = /\b(?P<severity>DEBUG|TRACE|FATAL|[Ii](?:nfo|NFO)|[Ww](?:arn(?:ing)?|ARN(?:ING)?)|[Ee](?:rror|RROR|xception|XCEPTION))\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?P<severity>DEBUG|TRACE|FATAL|[Ii](?:nfo|NFO)|[Ww](?:arn(?:ing)?|ARN(?:ING)?)|[Ee](?:rror|RROR|xception|XCEPTION))\\b', 'gm')
const str = `{"exception":"","severity":"Warn ","SRC":"CardholderProcessorService.DAL.DataFunctions.UpdateCardNotValid ","xFor":"","w":"","PID":"3848 ","message":"Card was not issued (CardholderId=3946418 DebitCardId=4366182403580205). Please check card application. Reason: {City: Invalid behavior for CPS_City: City does not match regex: ^[a-zA-Z\\\\\\\\.][a-zA-Z\\\\\\\\. ]*[a-zA-Z\\\\\\\\.]\$.} Details: City has to be letters only, no numbers or dashes or commas or any other characters. Spaces should only be 1 space long","TID":"121 ","Url":"","SId":"","VSID":"5 ","site":"HRZ","REF":"","TKID":"","CSys":"","response":"","AHID":"","timestamp":"2019-09-04 00:20:31.1409 ","CID":"311aca82-7056-49a1-93b1-0d0da802f976 ","CHID":""}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}