#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?<!-)(?=(?:[a-z\d-]*[A-Z]){2})[A-Za-z\d]+(?:-[A-Za-z\d]+)*\b(?!-)"
Local $sString = "ABC" & @CRLF & _
"AbC" & @CRLF & _
"ABc" & @CRLF & _
"A-ABC" & @CRLF & _
"a-ABC" & @CRLF & _
"ABC-a" & @CRLF & _
"ABC123" & @CRLF & _
"ABC-123" & @CRLF & _
"123-ABC" & @CRLF & _
"BC" & @CRLF & _
"" & @CRLF & _
"this is a testAB" & @CRLF & _
"" & @CRLF & _
"A-bc a-b-c" & @CRLF & _
"" & @CRLF & _
"-AA-----" & @CRLF & _
"" & @CRLF & _
"ABC, AbC, ABc, A-ABC, a-ABC, ABC-a, ABC123, ABC-123, 123-ABC."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")