import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!-)(?=(?:[a-z\\d-]*[A-Z]){2})[A-Za-z\\d]+(?:-[A-Za-z\\d]+)*\\b(?!-)";
final String string = "ABC\n"
+ "AbC\n"
+ "ABc\n"
+ "A-ABC\n"
+ "a-ABC\n"
+ "ABC-a\n"
+ "ABC123\n"
+ "ABC-123\n"
+ "123-ABC\n"
+ "BC\n\n"
+ "this is a testAB\n\n"
+ "A-bc a-b-c\n\n"
+ "-AA-----\n\n"
+ "ABC, AbC, ABc, A-ABC, a-ABC, ABC-a, ABC123, ABC-123, 123-ABC.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}