re = /\b(?<!-)(?=(?:[a-z\d-]*[A-Z]){2})[A-Za-z\d]+(?:-[A-Za-z\d]+)*\b(?!-)/m
str = 'ABC
AbC
ABc
A-ABC
a-ABC
ABC-a
ABC123
ABC-123
123-ABC
BC
this is a testAB
A-bc a-b-c
-AA-----
ABC, AbC, ABc, A-ABC, a-ABC, ABC-a, ABC123, ABC-123, 123-ABC.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end