use strict;
my $str = 'https://www.notion.so/owoy/a74a111111111111b55dafa3512d1c4d?v=b012aaaaac7d4cf7a07cf76c3c11111c';
my $regex = qr/(?:\/([\w\d]+)\?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}