// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{2} de ((Jan|Fever)eiro|(Març|Mai)o|Abril|Ju[ln]ho|Agosto|(Setem|Outu|Novem|Dezem)bro) de \d{4}.+\d{2}:\d{2}:\d{2}").unwrap();
let string = "17 de Janeiro de 2008 às 11:35:04
17 de Fevereiro de 2008 às 11:35:04
17 de Março de 2008 às 11:35:04
17 de Abril de 2008 às 11:35:04
17 de Maio de 2008 às 11:35:04
17 de Junho de 2008 às 11:35:04
17 de Julho de 2008 às 11:35:04
17 de Agosto de 2008 às 11:35:04
17 de Setembro de 2008 às 11:35:04
17 de Outubro de 2008 às 11:35:04
17 de Novembro de 2008 às 11:35:04
17 de Dezembro de 2008 às 11:35:04
17 de mêsInválido de 2008 às 11:35:04
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}