import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<title.*?>(.*?)<\\/title>";
final String string = "<!doctype html>\\n<html lang=\\\"en\\\" itemscope itemtype=\\\"https://schema.org/WebPage\\\">\\n<head>\\n<meta charset=\\\"utf-8\\\"><meta name=\\\"referrer\\\" content=\\\"always\\\" />\\n<title itemprop=\\\"name\\\">title I need to select.</title>\\n<meta itemprop=\\\"description\\\" name=\\\"description\\\" content=\\><title itemprop=\\\"name\\\">title I need to select.</title>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}