use strict;
my $str = '<!doctype html>\\n<html lang=\\"en\\" itemscope itemtype=\\"https://schema.org/WebPage\\">\\n<head>\\n<meta charset=\\"utf-8\\"><meta name=\\"referrer\\" content=\\"always\\" />\\n<title itemprop=\\"name\\">title I need to select.</title>\\n<meta itemprop=\\"description\\" name=\\"description\\" content=\\><title itemprop=\\"name\\">title I need to select.</title>';
my $regex = qr/<title.*?>(.*?)<\/title>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}