// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<title.*?>(.*?)<\/title>").unwrap();
let string = "<!doctype html>\\n<html lang=\\\"en\\\" itemscope itemtype=\\\"https://schema.org/WebPage\\\">\\n<head>\\n<meta charset=\\\"utf-8\\\"><meta name=\\\"referrer\\\" content=\\\"always\\\" />\\n<title itemprop=\\\"name\\\">title I need to select.</title>\\n<meta itemprop=\\\"description\\\" name=\\\"description\\\" content=\\><title itemprop=\\\"name\\\">title I need to select.</title>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}