Group device_name(?P<device_name>\w+) \w+any word character, repeated at least once
Group is_connected(?P<is_connected> (connected|disconnected)) the literal (3210 / 408 / 2016)
Group 3(connected|disconnected) connectedthe literal text connected (case sensitive) 2nd Alternativedisconnected disconnectedthe literal text disconnected (case sensitive) Group is_primary(?P<is_primary> primary)? ?repeats the group contents below at most once:
primarythe literal text primary (case sensitive) the literal (3210 / 408 / 2016)
Group 5((?P<resolution_width>\d+)x(?P<resolution_height>\d+)\+(?P<offset_width>\d+)\+(?P<offset_height>\d+)) Group resolution_width(?P<resolution_width>\d+) \d+a digit, repeated at least once
xthe literal x (12010 / 1708 / 7816) (case sensitive)
Group resolution_height(?P<resolution_height>\d+) \d+a digit, repeated at least once
\+the literal + (4310 / 538 / 2B16)
Group offset_width(?P<offset_width>\d+) \d+a digit, repeated at least once
\+the literal + (4310 / 538 / 2B16)
Group offset_height(?P<offset_height>\d+) \d+a digit, repeated at least once
the literal (3210 / 408 / 2016)
\(the literal ( (4010 / 508 / 2816)
normal left inverted right x axis y axisthe literal text normal left inverted right x axis y axis (case sensitive) \)the literal ) (4110 / 518 / 2916)
the literal (3210 / 408 / 2016)
Group 10((?P<dimension_width>\d+)mm x (?P<dimension_height>\d+)mm)? ?repeats the group contents below at most once:
Group dimension_width(?P<dimension_width>\d+) \d+a digit, repeated at least once
mm x the literal text mm x (case sensitive) Group dimension_height(?P<dimension_height>\d+) \d+a digit, repeated at least once
mmthe literal text mm (case sensitive) g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string