#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s{4}\(bingo\).*\s"
Local $sString = "(" & @CRLF & _
" (text " & @CRLF & _
" (bingo) <-- keep this (level=3)" & @CRLF & _
" text)" & @CRLF & _
" (text)" & @CRLF & _
" (bingo) <-- kick this (level=2)" & @CRLF & _
" (text)" & @CRLF & _
")"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)