import Foundation
let pattern = #"^\s{4}\(bingo\).*\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(
(text
(bingo) <-- keep this (level=3)
text)
(text)
(bingo) <-- kick this (level=2)
(text)
)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)