package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:[1-9]|[1-9](?:\d{1,2})|10[0-2][0-3])(?:[KM])|(?:[1-9]|[1-3][0-9]|40)G)$`)
var str = `40G`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}