Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
^(?:(?:[1-9]|[1-9](?:\d{1,2})|10[0-2][0-3])(?:[KM])|(?:[1-9]|[1-3][0-9]|40)G)$
"
gm
Input 1
1
New
40G