re = /^(?:(?:[1-9]|[1-9](?:\d{1,2})|10[0-2][0-3])(?:[KM])|(?:[1-9]|[1-3][0-9]|40)G)$/m
str = '40G'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end