# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https?:\/\/([^\/]+)\S*/(link from $1)/gm;t' <<< "https://www.youtube.com/watch?=whatever\""