#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)https?://([^/]+)\S*"
Local $sString = "https://www.youtube.com/watch?=whatever""
Local $sSubst = "(link from $1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)