using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://([^/]+)\S*";
string substitution = @"(link from $1)";
string input = @"https://www.youtube.com/watch?=whatever""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}