// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?://([^/]+)\S*").unwrap();
let string = "https://www.youtube.com/watch?=whatever\"";
let substitution = "(link from $1)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}