const regex = new RegExp('(?<!\\.)(\\b[a-zA-Z_]+[a-zA-Z0-9_]+)\\.[a-zA-Z0-9_\\.]+', 'g')
const str = `module.func()
module.class.func()
module.module.class . func()
__module__.module.class.func()
module.constant
module.class.constant
module.class.class.constant
module11.func()
modu123le.class.func()
modu123le.module.class.func()
modu123le.module123.class.func()
"1 if module11.func(col) == 'A' else 3"
"1 if module11.func(col) == 'A' else ( _module.constant == 'B') else 34"
"module.func()"
1.0
1module.func()
2module.class.func()
col.upper() ##No way to know whether col is a module
module . func() ##Need to remove spaces before and after .
module . class . func()
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}