import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Material Tracking\\n=================\\nMaterial I.D. Port # Cassette Slots \\n------------- ------ -------------- \\n(\\S+)\\s+Port (\\d) : ([0-9 ]+)\\n([\\w\\s]+):\\s+(\\d+)\\s\\n\\nParameter #1";
final String string = "Material Tracking\n"
+ "=================\n"
+ "Material I.D. Port # Cassette Slots \n"
+ "------------- ------ -------------- \n"
+ "SNF713.1 Port 2 : 14 15 16 17 18 19 20 21 22 23 24 25 \n"
+ "DUMMY WAFERS : 16 \n\n"
+ "Parameter #1 Avg. #1 Std.Dev. #2 Avg. #2 Std.Dev. ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}