use strict;
my $str = 'Material Tracking
=================
Material I.D. Port # Cassette Slots
------------- ------ --------------
SNF713.1 Port 2 : 14 15 16 17 18 19 20 21 22 23 24 25
DUMMY WAFERS : 16
Parameter #1 Avg. #1 Std.Dev. #2 Avg. #2 Std.Dev. ';
my $regex = qr/Material Tracking\n=================\nMaterial I.D. Port # Cassette Slots \n------------- ------ -------------- \n(\S+)\s+Port (\d) : ([0-9 ]+)\n([\w\s]+):\s+(\d+)\s\n\nParameter #1/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}