import re
regex = re.compile(r"Material Tracking\n=================\nMaterial I.D. Port # Cassette Slots \n------------- ------ -------------- \n(\S+)\s+Port (\d) : ([0-9 ]+)\n([\w\s]+):\s+(\d+)\s\n\nParameter #1", flags=re.MULTILINE)
test_str = ("Material Tracking\n"
"=================\n"
"Material I.D. Port # Cassette Slots \n"
"------------- ------ -------------- \n"
"SNF713.1 Port 2 : 14 15 16 17 18 19 20 21 22 23 24 25 \n"
"DUMMY WAFERS : 16 \n\n"
"Parameter #1 Avg. #1 Std.Dev. #2 Avg. #2 Std.Dev. ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")