import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^spotify\\/streams\\/\\d{8}\\/[A-Z]{2}_streams_\\d{8}\\.csv";
final String string = "spotify/streams/20200819/NL_streams_20200819.csv\n"
+ "spotify/streams/20200819/nl_streams_20200819.csv\n"
+ "test/spotify/tracks\n"
+ "spotify/tracks/hello.world";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}