$re = '/^spotify\/streams\/\d{8}\/[A-Z]{2}_streams_\d{8}\.csv/m';
$str = 'spotify/streams/20200819/NL_streams_20200819.csv
spotify/streams/20200819/nl_streams_20200819.csv
test/spotify/tracks
spotify/tracks/hello.world';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);