import Foundation
let pattern = #"^spotify\/streams\/\d{8}\/[A-Z]{2}_streams_\d{8}\.csv"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
spotify/streams/20200819/NL_streams_20200819.csv
spotify/streams/20200819/nl_streams_20200819.csv
test/spotify/tracks
spotify/tracks/hello.world
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)