re = /^\[START\]client\.(?<type>\w+)\n(?<value>.*)\n\[END\]client\.\w+$/m
str = '[START]client.mail
exemple@exemple.com
[END]client.mail
[START]client.ville
Marseille
[END]client.ville'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end