re = /^([sS][gG][1|4]|[aA][lL][6-7|10|2-3]|[wW][dD][23|25|7|4]|[hH][pP][1|3-4]|[lL][uU]1)\d?\b/m
str = 'SG1
SG4
AL2
AL6
AL7
AL10
WD4
WD7
WD23
WD25
HP1
HP3
HP4
LU1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end