$re = '/^(?!database|audit|index|analysis|extract|good|bad).*$/m';
$str = 'database
audit
index
analysis
extract
good
bad
hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);