using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"id \[([\d\w-]*)\]";
string input = @"Error: GraphQL error: Fetch failure: HTTP 500 'Internal Server Error' for
https://localhost:3000: Unhandled command [https://localhost:3000.AddTag]
in [https://localhost:3000.AccountEntity]
with id [7f4cd122-4f1e-53bb-8501-68fc525bb1cd]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}