package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)id \[([\d\w-]*)\]`)
var str = `Error: GraphQL error: Fetch failure: HTTP 500 'Internal Server Error' for
https://localhost:3000: Unhandled command [https://localhost:3000.AddTag]
in [https://localhost:3000.AccountEntity]
with id [7f4cd122-4f1e-53bb-8501-68fc525bb1cd]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}