import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "id \\[([\\d\\w-]*)\\]";
final String string = "Error: GraphQL error: Fetch failure: HTTP 500 'Internal Server Error' for\n"
+ "https://localhost:3000: Unhandled command [https://localhost:3000.AddTag]\n"
+ "in [https://localhost:3000.AccountEntity] \n"
+ "with id [7f4cd122-4f1e-53bb-8501-68fc525bb1cd]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}