$re = '/id \[([\d\w-]*)\]/m';
$str = 'Error: GraphQL error: Fetch failure: HTTP 500 \'Internal Server Error\' for
https://localhost:3000: Unhandled command [https://localhost:3000.AddTag]
in [https://localhost:3000.AccountEntity]
with id [7f4cd122-4f1e-53bb-8501-68fc525bb1cd]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);